L08084のブログ

技術記事の執筆は、祈りに近い

エラー「angular/compiler-cliが適切にインストールされてません」

遭遇したエラー

"@angular/compiler-cli" package was not properly installed. Error: Error: Cannot find module '@angular/compiler-cli'

npm installをした後に、ng serveコマンドでアプリを起動しようとした時に発生しました。

バージョン情報

  • angular/cli: 1.6.5

  • Angular: 5.2.3

  • Typescript: 2.4.2

  • OS: darwin x64

  • Node: 8.1.4

エラーの修正手順

node_modulesを削除した後に、再度npm installコマンドを実行することで解決できます。